по мотивам наших публикаций

«Загадочные работники»(tm) вместо ADSL предложили MetroEthernet.
А вот новый маршрутизатор бесплатно не предложили, пришлось выкручиваться с имеющимся cisco 877-K9.
Для тех, кто не в курсе — по дефолту у него все 4 ethernet-порта находятся в Vlan 1, а «внешним» является порт ADSL-модема (интерфейс ATM0).
Но мы же уже знаем, что для тестов (т.е. исключительно в ознакомительных целях) можно использовать c870-advipservicesk9-mz.124-11.T2.bin, позволяющий создавать Vlan 2. Отличие от предыдущего эксперимента в том, что ранеее мы разделяли на влан-ы внутренние порты, а в данном случае мы используем Vlan 2 для использования FastEthernet 3 в качестве «внешнего» интерфейса.


!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0
no cdp enable
!
interface FastEthernet1
no cdp enable
!
interface FastEthernet2
no cdp enable
!
interface FastEthernet3
switchport access vlan 2
no cdp enable
!
interface Vlan1
ip address IP.IP.IP.IP MASK.MASK.MASK.MASK
no ip route-cache
!
interface Vlan2
pppoe enable group global
pppoe-client dial-pool-number 1
no ip address
!
interface Dialer1
ip address negotiated
ip mtu 1492
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer idle-timeout 0
dialer persistent delay initial 5
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname pppoe-XXXXXX
ppp chap password 7 PASSWORD
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
!
access-list 105 permit icmp any any
dialer-list 1 protocol ip permit
no cdp run
!

Напоминаю, что Vlan 2 не только прописывается в конфиге, но и предварительно создаётся командой vlan database (и далее подсказкой).

Никакие NAT-ы и прочее я тут не описываю, т.к. в моём конкретном случае это не нужно, а кому понадобится — есть описание в постах с этими же тегами, но чуть ранее.

Запись опубликована в рубрике cisco, cisco 877, work, дальсвязь. Добавьте в закладки постоянную ссылку.

Добавить комментарий